Apple devices are known to have several issues with captive portal hotspots. While specific behavior will depend on a particular device model, OS version and possibly other factors such as geographic location, and as such might or might not present themselves, there are a few workarounds that might do the trick for your device.

Social WiFi does not take responsibility for any issues resulting from either hotspot issues experienced by your device nor the results of the following workarounds. For all intents and purposes, Apple devices having issues with displaying, connecting to or remaining connected to Social WiFi captive portal or network is not necessarily indicative of problems with Social WiFi service.

1. Apple devices disconnect from hotspot

Thread on Apple’s official forums

Another thread on Apple’s official developers’ forums

Link to a GitHub thread regarding Apple devices disconnecting after locking the screen

2. Apple devices not displaying captive portal after connection

Being able to access Social WiFi captive portal is necessary in order to receive full internet access.

Thread on Apple’s official forums

Another thread on Apple’s official forums

Yet another thread on Apple’s official forums

Apple official troubleshooting guide

Our hotspot networks use the address 10.8.0.1 as captive portal gateway. As per information provided in the discussions linked above, typing that address in your address bar might enforce captive portal to show up.

3. Captive portal networks working slowly on Apple devices or not loading

Thread on Apple’s developers’ forums

Thread on Reddit regarding issues with Apple captive portals

Thread on Ubiquiti forums regarding issues with loading a captive portal

Tags

Comments are closed